Ubuntu 编译 AospExtended 填坑过程记录

/ 1评 / 0

错误一

FAILED: /home/paoge/aex/out/target/product/h930/obj_arm/RENDERSCRIPT_BITCODE/libclcore.bc_intermediates/rs_cl.bc 
/bin/bash -c "PWD=/proc/self/cwd prebuilts/clang/host/linux-x86/clang-3289846/bin/clang -Iframeworks/rs/script_api/include -Iexternal/clang/lib/Headers -MD -DRS_VERSION=24 -std=c99 -c -O3 -fno-builtin -emit-llvm -target renderscript32-linux-androideabi -fsigned-char  -Wno-deprecated -Werror  -Werror -Wall -Wextra -Iframeworks/rs/cpu_ref -DRS_DECLARE_EXPIRED_APIS  -x renderscript frameworks/rs/driver/runtime/rs_cl.c -o /home/paoge/aex/out/target/product/h930/obj_arm/RENDERSCRIPT_BITCODE/libclcore.bc_intermediates/rs_cl.bc"

安装lib32ncurses5试试解决

<span class="hljs-built_in">sudo</span> apt-get install lib32ncurses5:i386

不行还是报错,按照提示说没有共享?那就find下看看

paoge@lifegood:~$ sudo find / -name libncurses.so.5
find: ‘/run/user/1000/doc’: 权限不够
find: ‘/run/user/1000/gvfs’: 权限不够
/lib/i386-linux-gnu/libncurses.so.5
/lib32/libncurses.so.5
find: ‘/proc/3614/task/3614/net’: 无效的参数
find: ‘/proc/3614/net’: 无效的参数
/home/paoge/aex/prebuilts/gcc/linux-x86/host/x86_64-linux-glibc2.15-4.8/sysroot/usr/lib/libncurses.so.5
/home/paoge/aex/prebuilts/gcc/linux-x86/host/x86_64-linux-glibc2.15-4.8/sysroot/usr/lib32/libncurses.so.5
/snap/core/5662/lib/x86_64-linux-gnu/libncurses.so.5
/snap/core/6130/lib/x86_64-linux-gnu/libncurses.so.5

没在usr/lib下看到libncurses.so.5

那我添加一个ln试试

sudo ln -s /snap/core/5662/lib/x86_64-linux-gnu/libncurses.so.5  /usr/lib/libncurses.so.5

make了下妥了开始跑了

 

错误二

build/make/core/base_rules.mk:260: error: hardware/qcom/msm8998/json-c: 
MODULE.TARGET.SHARED_LIBRARIES.libjson already defined by external/json-c.
21:47:30 ckati failed with: exit status 1

删除 external/json-c 的json-c

 

错误三

/home/paoge/aex/kernel/lge/msm8998/scripts/extract-cert.c:21:10: fatal error: openssl/bio.h: 没有那个文件或目录
 #include <openssl/bio.h>
          ^~~~~~~~~~~~~~~
/home/paoge/aex/kernel/lge/msm8998/scripts/sign-file.c:23:10: fatal error: openssl/opensslv.h: 没有那个文件或目录
 #include <openssl/opensslv.h>
          ^~~~~~~~~~~~~~~~~~~~

安装libssldev

sudo apt install libssl-dev

 

一条回应:“Ubuntu 编译 AospExtended 填坑过程记录”

  1. 为每一个家庭提供及时的智能健康服务,让每一个人都能拥有轻松舒适的健康生活

发表评论

电子邮件地址不会被公开。 必填项已用*标注